• WxCenter Updates

    From Codefenix@VERT/CONCHAOS to All on Monday, January 01, 2024 12:57:53
    To any Sync sysops using my WxCenter mod, you'll want to update to the latest version. Simply grab the latest wxcenter.js file from https://github.com/codefenix-ConChaos/WxCenter and overwrite your old one.

    The geocoding API service that I had been using for key-less API calls was recently changed to require API keys for all requests. While these API keys are free, I did not want sysops to have to get a key from a second service in order to run this mod.

    So the solution I decided on was to call OpenWeatherMap.org's own geocoding service if the sysop already has an API key from there.

    Or, if the sysop chooses to not get an API key at all, it will instead use OpenStreetMap for key-less geocoding API calls, and get still get weather data from Weather.gov for the location returned.

    |01<|09co|03d|11e|15|11e|03n|09ix|01>|07


    ...Die, my dear doctor? That's the last thing I shall do.
    ---
    Synchronet -=[ ConstructiveChaos BBS | conchaos.synchro.net ]=-
  • From Nightfox@VERT/DIGDIST to Codefenix on Monday, January 01, 2024 12:30:47
    Re: WxCenter Updates
    By: Codefenix to All on Mon Jan 01 2024 12:57 pm

    To any Sync sysops using my WxCenter mod, you'll want to update to the latest version. Simply grab the latest wxcenter.js file from https://github.com/codefenix-ConChaos/WxCenter and overwrite your old one.

    Thanks!

    Nightfox

    ---
    Synchronet Digital Distortion: digitaldistortionbbs.com
  • From The Lizard Master@VERT/NITEEYES to Codefenix on Monday, January 01, 2024 17:22:14
    Re: WxCenter Updates
    By: Codefenix to All on Mon Jan 01 2024 12:57 pm

    To any Sync sysops using my WxCenter mod, you'll want to update to the

    I use it, it's awesome. And thanks!

    ---
    Synchronet This is my tagline so I don't get any complaints when I post