• cdcacm modem, device_reference, Multitech modem

    From Simon Geddes@1:103/705 to All on Friday, August 09, 2019 13:48:43
    Hi all,

    First post in this echo..very glad to be here!

    I have a Multitech Multimodem ZBA USB to serial modem. I plug it into my Lubuntu set up and it works beautifully, giving me a /dev/serial/ directory and
    a modem lit up and ready for serial action!

    As this is a cdcacm modem, I believe it uses some modeswitch byte sequence to initiate it, which is usually kept in a device reference file. However I have been informed that this modem is supported at a kernel level and its reference is therefore missing from the device reference file which other cdcacm modems require (I think these are typically 3g cell network modems - mine is a landline device).

    When I open dev/serial// there are two files in there which are both symbolic links. I don't really know what that means, not being very au fait with Linux. I've tried to copy those files to external media without success. I've also tried to open the files (required sudo) to see if they contain any sort of sequence of bytes which the modem is using it initiate itself.

    Why am I bothered about this if it's working? I want to try and get it working under MorphOS (an Amiga-like OS for PPC hardware) and think this byte sequence holds the key. Then again, it might not.

    Apologies for the ramble. Hoping some of this might make sense to someone who can point me in the right direction. It doesn't make much sense to me!
    --- SBBSecho 3.08-Linux
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)