• Problem polling Fidonet

    From HusTler@1:103/705 to All on Friday, August 23, 2019 09:52:00
    Hi. I haven't recieved any new messages from Fidonet. Here's my lost poll results:

    09:39:24 evnt BINKPOLL Attempting poll for node 1:267/800@fidonet
    8/23 09:39:24 evnt BINKPOLL JSBinkP/1.121 callout to 1:267/800@fidonet started 8/23 09:39:24 evnt BINKPOLL Connecting to 1:267/800@fidonet at capitalhub.dyndns.org:24555
    8/23 09:39:29 evnt BINKPOLL Peer version: Mystic/1.12A43 binkp/1.0
    8/23 09:39:29 evnt BINKPOLL Authentication successful: secure
    8/23 09:39:30 evnt BINKPOLL Receiving file: /sbbs/temp/event/00000280.fr0 (4194304.0KB)
    8/23 09:39:30 evnt BINKPOLL Timed out receiving packet data from remote: 1:267/800@fidonet,1:267/0@fidonet
    8/23 09:39:30 evnt BINKPOLL Failed to receive the whole file '/sbbs/temp/event/00000280.fr0'.

    Does anyone know whats going on with "Failed to recieve whole file" ? What could be the cause? What would cause a time out?

    ---
    Synchronet Havens BBS havens.synchro.net
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From echicken@1:103/705 to HusTler on Friday, August 23, 2019 13:14:38
    Re: Problem polling Fidonet
    By: HusTler to echicken on Fri Aug 23 2019 12:34:27

    Looks like the last update to BINKIT was 2 months ago. The problem is
    about a week old. Is it safe
    to say an update is not causing this? I just want to make sure I'm looking
    in the right place. ;-)

    That's hard to say for sure. The main BinkIT script was updated two months ago, but other scripts that it depends on have been updated since then.

    This could be a bug on our end, or it could be your hub trying to send something corrupt. At a glance it looks like they're sending you a bogus file size and then potentially a nearly empty file (that's a rough guess on my part). However, maybe BinkIT is handling the file size incorrectly or something.

    Are you receiving *anything* from this remote host, or is this preventing it altogether?

    I wonder if anyone else is seeing similar problems. I have nothing like it in my log.

    ---
    echicken
    electronic chicken bbs - bbs.electronicchicken.com
    Synchronet electronic chicken bbs - bbs.electronicchicken.com
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From HusTler@1:103/705 to echicken on Friday, August 23, 2019 12:34:27
    Re: Problem polling Fidonet
    By: echicken to HusTler on Fri Aug 23 2019 11:01 am

    8/23 09:39:30 evnt BINKPOLL Receiving file: /sbbs/temp/event/00000280.fr0 (4194304.0KB)
    8/23 09:39:30 evnt BINKPOLL Timed out receiving packet data from remote:
    Looks like the last update to BINKIT was 2 months ago. The problem is about
    a week old. Is it safe to say an update is not causing this? I just want to make sure I'm looking in the right place. ;-)

    ---
    Synchronet Havens BBS havens.synchro.net
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From HusTler@1:103/705 to echicken on Friday, August 23, 2019 12:12:00
    Re: Problem polling Fidonet
    By: echicken to HusTler on Fri Aug 23 2019 11:01 am

    Judging by the timestamps in your log, this isn't a timeout even though the message says otherwise.

    Looks like the remote side started transferring a file, maybe included a bad packet header, then sent nothing more.

    The size of the file looks suspect: 4194304.0KB

    Thank you for your reply. I suspected the problem might be from my hub as I haven't made any changes in my config or Areafix in a long while. It was working fine up until a week ago. I have sent my coordinator an email but he's quick to deny something is ever wrong on his end. Let's see how it goes. Hopefully BINKP notifies the SysOp when a transfer isn't complete. Thank you again.

    ---
    Synchronet Havens BBS havens.synchro.net
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Digital Man@1:103/705 to echicken on Friday, August 23, 2019 11:58:57
    Re: Problem polling Fidonet
    By: echicken to HusTler on Fri Aug 23 2019 11:01 am

    Re: Problem polling Fidonet
    By: HusTler to All on Fri Aug 23 2019 09:52:00

    8/23 09:39:30 evnt BINKPOLL Receiving file: /sbbs/temp/event/00000280.fr0 (4194304.0KB)
    8/23 09:39:30 evnt BINKPOLL Timed out receiving packet data from remote:

    Judging by the timestamps in your log, this isn't a timeout even though the message says otherwise.

    Yeah, I saw that too.

    Looks like the remote side started transferring a file, maybe included a bad packet header, then sent nothing more.

    Does anyone know whats going on with "Failed to recieve whole file" ? What could be the cause? What would cause a time out?

    The size of the file looks suspect: 4194304.0KB

    Yeah, that value looks suspicously like 0xffffffff (-1).

    There could be a bug in BinkIT, but this could also be something weird going on at your hub. Maybe ask if they see anything weird waiting for you there.
    I suspect the sending system is having some issue.

    digital man

    Synchronet "Real Fact" #46:
    Synchronet External X/Y/ZMODEM protocol driver (SEXYZ) was introduced in 2005. Norco, CA WX: 74.9F, 65.0% humidity, 0 mph NW wind, 0.00 inches rain/24hrs
    --- SBBSecho 3.09-Linux
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)