• Delay on web pages?

    From poindexter FORTRAN@1:103/705 to All on Thursday, August 29, 2019 23:03:00
    I'm trying to figure out what's going on with a pretty recent 3.17
    Synchronet install. Static web pages serve up quickly, and javascript pages do, too -- but the browser's spinning icon signifiying a page load
    continues to load for 5-7 seconds more.

    Any suggestions on where to look?

    Thanks!


    ... Have you ever asked a question you weren't supposed to ask?
    --- MultiMail/XT v0.52
    Synchronet realitycheckBBS -- http://realitycheckBBS.org
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Digital Man@1:103/705 to poindexter FORTRAN on Friday, August 30, 2019 03:40:31
    Re: Delay on web pages?
    By: poindexter FORTRAN to All on Thu Aug 29 2019 11:03 pm

    I'm trying to figure out what's going on with a pretty recent 3.17 Synchronet install. Static web pages serve up quickly, and javascript pages do, too -- but the browser's spinning icon signifiying a page load continues to load for 5-7 seconds more.

    Any suggestions on where to look?

    Thanks!

    Variables that might help to diagnose the issue:

    http or https or both?

    different browsers behave differently?

    what does the browser dev console say is happening?

    digital man

    Synchronet/BBS Terminology Definition #6:
    BinkD = Binkley Daemon
    Norco, CA WX: 71.0F, 67.0% humidity, 0 mph SSW wind, 0.00 inches rain/24hrs --- SBBSecho 3.09-Linux
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From echicken@1:103/705 to poindexter FORTRAN on Friday, August 30, 2019 08:08:28
    Re: Delay on web pages?
    By: poindexter FORTRAN to All on Thu Aug 29 2019 23:03:00

    I'm trying to figure out what's going on with a pretty recent 3.17 Synchronet install. Static web pages serve up quickly, and javascript
    pages
    do, too -- but the browser's spinning icon signifiying a page load continues to load for 5-7 seconds more.

    Any suggestions on where to look?

    It looks as though some script isn't finishing. How up-to-date is your web UI?

    Your sidebar never completely loads. It's possible that something in there is causing a problem. You can try temporarily moving items out of the sidebar/ directory one by one (staring with the nodelist / who's online module) to see if it helps.

    ---
    echicken
    electronic chicken bbs - bbs.electronicchicken.com
    Synchronet electronic chicken bbs - bbs.electronicchicken.com
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From mark lewis@1:3634/12.73 to poindexter FORTRAN on Friday, August 30, 2019 12:03:50
    On 2019 Aug 29 23:03:00, you wrote to All:

    I'm trying to figure out what's going on with a pretty recent 3.17 Synchronet install. Static web pages serve up quickly, and javascript pages do, too -- but the browser's spinning icon signifiying a page
    load continues to load for 5-7 seconds more.

    Any suggestions on where to look?

    if you use firefox, look at the Web Developer -> "Performance" and "Network" tools... start the performance tool recording and then load the web page in question... one or both should easily show you which parts are experiencing the
    slowdown... don't forget to stop the performace tool when finished with it ;)

    depending on your browser, it could also be preloading links so the site will appear faster...

    )\/(ark

    Once men turned their thinking over to machines in the hope that this would set
    them free. But that only permitted other men with machines to enslave them. ... Never underestimate the power of human stupidity.
    ---
    * Origin: (1:3634/12.73)
  • From poindexter FORTRAN@1:103/705 to Digital Man on Friday, August 30, 2019 10:16:16
    Re: Delay on web pages?
    By: Digital Man to poindexter FORTRAN on Fri Aug 30 2019 03:40 am

    Thanks for responding back so quickly regarding my web issue.


    Variables that might help to diagnose the issue:

    http or https or both?

    I only checked HTTP.

    different browsers behave differently?

    I've tried with Firefox and Chrome, same response.

    what does the browser dev console say is happening?

    I'll play with it at home, at work the javascript pages time out with the error

    ERR_INCOMPLETE_CHUNKED_ENCODING 200 (OK)

    ---
    Synchronet realitycheckBBS -- http://realitycheckBBS.org
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From poindexter FORTRAN@1:103/705 to echicken on Friday, August 30, 2019 10:19:54
    Re: Delay on web pages?
    By: echicken to poindexter FORTRAN on Fri Aug 30 2019 08:08 am

    It looks as though some script isn't finishing. How up-to-date is your web UI?

    I grabbed the sbbs_dev, sbbs_run zips and downloaded ecweb4 last night.

    Your sidebar never completely loads. It's possible that something in there is causing a problem. You can try temporarily moving items out of the sideb

    I thought I tried that, will try again.

    I was wondering if mismatched HTML like a <div> without a </div> would cause a problem, just grasping at straws.

    ---
    Synchronet realitycheckBBS -- http://realitycheckBBS.org
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From echicken@1:103/705 to poindexter FORTRAN on Friday, August 30, 2019 13:48:57
    Re: Delay on web pages?
    By: poindexter FORTRAN to Digital Man on Fri Aug 30 2019 10:16:16

    ERR_INCOMPLETE_CHUNKED_ENCODING 200 (OK)

    I *think* this was happening a while back but was fixed (in the webserver). I may be mistaken.

    You said your build was fairly recent. How recent is that?

    ---
    echicken
    electronic chicken bbs - bbs.electronicchicken.com
    Synchronet electronic chicken bbs - bbs.electronicchicken.com
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From poindexter FORTRAN@1:103/705 to echicken on Friday, August 30, 2019 14:22:47
    Re: Delay on web pages?
    By: echicken to poindexter FORTRAN on Fri Aug 30 2019 01:48 pm

    ERR_INCOMPLETE_CHUNKED_ENCODING 200 (OK)

    I *think* this was happening a while back but was fixed (in the webserver). I may be mistaken.

    You said your build was fairly recent. How recent is that?

    I'll have to look this weekend when I have some time in front of the BBS. . What file would have been fixed? I'd like to look through the CVS log.


    ---
    Synchronet realitycheckBBS -- http://realitycheckBBS.org
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From echicken@1:103/705 to poindexter FORTRAN on Friday, August 30, 2019 17:56:03
    Re: Delay on web pages?
    By: poindexter FORTRAN to echicken on Fri Aug 30 2019 14:22:47

    I'll have to look this weekend when I have some time in front of the BBS.
    .
    What file would have been fixed? I'd like to look through the CVS log.

    Probably websrvr.c, but could be something else. I only vaguely recall some kind of problem with chunked transfers within the past few months; this may be unrelated. If your build is 2+ months old it might be worth updating to see if
    it helps.

    ---
    echicken
    electronic chicken bbs - bbs.electronicchicken.com
    Synchronet electronic chicken bbs - bbs.electronicchicken.com
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From mark lewis@1:3634/12.73 to poindexter FORTRAN on Friday, August 30, 2019 20:58:38
    On 2019 Aug 30 14:22:46, you wrote to echicken:

    I'll have to look this weekend when I have some time in front of the BBS.
    .
    What file would have been fixed? I'd like to look through the CVS log.

    i think it was fixed in the Aug 2 updates to websrvr.c... not positive about that, though...

    )\/(ark

    Once men turned their thinking over to machines in the hope that this would set
    them free. But that only permitted other men with machines to enslave them. ... I don't own any slaves. My wife has one, though.
    ---
    * Origin: (1:3634/12.73)