• Can't seem to move files around

    From Codefenix@1:103/705 to Digital Man on Sunday, February 12, 2023 09:41:27
    Re: Can't seem to move files around
    By: Digital Man to Codefenix on Sat Feb 11 2023 11:59 am

    No, that's the right steps, it just sounds like a bug. I tried it myself and could reproduce the behavior you're describing.

    Most likely the bug was introduced with the addition of the new filebase support (v3.19), but nobody's reported it before now.

    OK, thanks for confirming.

    It doesn't look like there's any utility that moves files, so until the bug is fixed, I suppose I could move files around manually outside of SBBS and then use delfiles and addfiles to clean up the filebase. Is that the best option for now, or is there a cleaner method I'm overlooking?

    |01<|09co|03d|11e|15|11e|03n|09ix|01>|07
    ---
    Synchronet -=[ ConstructiveChaos BBS | conchaos.synchro.net ]=-
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Digital Man@1:103/705 to Codefenix on Sunday, February 12, 2023 14:08:30
    Re: Can't seem to move files around
    By: Codefenix to Digital Man on Sun Feb 12 2023 09:41 am

    Re: Can't seem to move files around
    By: Digital Man to Codefenix on Sat Feb 11 2023 11:59 am

    No, that's the right steps, it just sounds like a bug. I tried it myself and could reproduce the behavior you're describing.

    Most likely the bug was introduced with the addition of the new filebase support (v3.19), but nobody's reported it before now.

    OK, thanks for confirming.

    It doesn't look like there's any utility that moves files, so until the bug is fixed, I suppose I could move files around manually outside of SBBS and then use delfiles and addfiles to clean up the filebase. Is that the best option for now, or is there a cleaner method I'm overlooking?

    I already committed the fix. And the bug did no exist in v3.19 after-all.
    --
    digital man (rob)

    Sling Blade quote #18:
    Karl Childers: Some folks call it Hell, I call it Hades.
    Norco, CA WX: 56.9F, 53.0% humidity, 8 mph SE wind, 0.00 inches rain/24hrs
    --- SBBSecho 3.20-Linux
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Codefenix@1:103/705 to Digital Man on Monday, February 13, 2023 08:45:33
    Re: Can't seem to move files around
    By: Digital Man to Codefenix on Sun Feb 12 2023 02:08 pm

    I already committed the fix. And the bug did no exist in v3.19 after-all.

    Nice! Confirmed working in ae44ab153.

    |01<|09co|03d|11e|15|11e|03n|09ix|01>|07
    ---
    Synchronet -=[ ConstructiveChaos BBS | conchaos.synchro.net ]=-
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Codefenix@1:103/705 to All on Saturday, February 11, 2023 11:09:55
    I'm trying to move files from my Main-Uploads directory to other directories from within the BBS.

    I list the files in my Uploads directory, press the sysop key M and select the file I want to move, then select the appropriate library & directory for it, at which point the file size color changes red and has a red hyphen next to it, which I assume denotes a file move in progress. I repeat this for the rest of the files I want to move, and exit the list. When I re-list the Uploads directory, I find that the files I tried to move are still there instead of having moved, and the file size color back to normal.

    I feel like I'm missing something obvious and skipping a step.

    |01<|09co|03d|11e|15|11e|03n|09ix|01>|07
    ---
    Synchronet -=[ ConstructiveChaos BBS | conchaos.synchro.net ]=-
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Digital Man@1:103/705 to Codefenix on Saturday, February 11, 2023 11:59:48
    Re: Can't seem to move files around
    By: Codefenix to All on Sat Feb 11 2023 11:09 am

    I'm trying to move files from my Main-Uploads directory to other directories from within the BBS.

    I list the files in my Uploads directory, press the sysop key M and select the file I want to move, then select the appropriate library & directory for it, at which point the file size color changes red and has a red hyphen next to it, which I assume denotes a file move in progress. I repeat this for the rest of the files I want to move, and exit the list. When I re-list the Uploads directory, I find that the files I tried to move are still there instead of having moved, and the file size color back to normal.

    I feel like I'm missing something obvious and skipping a step.

    No, that's the right steps, it just sounds like a bug. I tried it myself and could reproduce the behavior you're describing.

    Most likely the bug was introduced with the addition of the new filebase support (v3.19), but nobody's reported it before now.
    --
    digital man (rob)

    Synchronet "Real Fact" #66:
    Synchronet was conceived of and mostly developed in southern California
    Norco, CA WX: 61.0F, 53.0% humidity, 2 mph E wind, 0.00 inches rain/24hrs
    --- SBBSecho 3.20-Linux
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)