• SBBSEcho and BRE

    From Underminer@1:103/705 to digital man on Friday, July 17, 2020 17:39:48
    Hello and good day.

    So prior to migrating the board over to Linux, I figured I'd update Synchronet on the windows box it's running on in case there were changes and tweaks to be adjusted and experimented with. Updating to the most recent 3.17 release, I noticed SBBSEcho wasn't tossing packets from BRE. Reading through your commit logs I saw that you'd made a fix, so did a nightly build of SBBS from CVS.

    SBBSEcho now tosses BRE packets again.... but not to anything resembling the correct address. The address it should be going to (169:1/107) is coming out as either 1:13361/8224 or 1:12602/8240, and the from address is coming out as either 1:14896/13873 or 1:12340/12576 depending on whether I let SBBSEcho toss the netmail message as is, or edit it to remove the ^ before the file path.

    I've tested sending straight netmail, and that routes fine, so it's not my node settings. Anyways, not a huge deal given that I'll be running it with dosemu once I move it over to the new system anyways, so will have to do some workarounds with file paths at least so can likely just write a bash script to cleanup the message in general.

    Just figured it might be causing someone else some significant frustration, so I should mention it. I only seem to be seeing it with BRE and FE.
    ---
    Underminer
    The Undermine BBS - bbs.undermine.ca:423
    Fidonet: 1:342/17
    ---
    Synchronet The Undermine - bbs.undermine.ca
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Digital Man@1:103/705 to Underminer on Saturday, July 18, 2020 16:39:26
    Re: SBBSEcho and BRE
    By: Underminer to digital man on Fri Jul 17 2020 05:39 pm

    Hello and good day.

    So prior to migrating the board over to Linux, I figured I'd update Synchronet on the windows box it's running on in case there were changes and tweaks to be adjusted and experimented with. Updating to the most recent 3.17 release, I noticed SBBSEcho wasn't tossing packets from BRE. Reading through your commit logs I saw that you'd made a fix, so did a nightly build of SBBS from CVS.

    SBBSEcho now tosses BRE packets again.... but not to anything resembling the correct address. The address it should be going to (169:1/107) is coming out as either 1:13361/8224 or 1:12602/8240, and the from address is coming out as either 1:14896/13873 or 1:12340/12576 depending on whether I let SBBSEcho toss the netmail message as is, or edit it to remove the ^ before the file path.

    I've tested sending straight netmail, and that routes fine, so it's not my node settings. Anyways, not a huge deal given that I'll be running it with dosemu once I move it over to the new system anyways, so will have to do some workarounds with file paths at least so can likely just write a bash script to cleanup the message in general.

    Just figured it might be causing someone else some significant frustration, so I should mention it. I only seem to be seeing it with BRE and FE.

    Would be happy to address the issue, but I don't use BRE, so you'll have to give more details. What file ie BRE creating, exactly? If it's a packet, have you tried using any fido packet viewing utils (e.g. my pktdump.exe) to see exactly how the message header (e.g. the from address) is being created? A little more debugging on your end is going to be needed to identify where the issue is.

    digital man

    This Is Spinal Tap quote #7:
    Nigel Tufnel: That's just nitpicking, isn't it?
    Norco, CA WX: 86.8F, 41.0% humidity, 11 mph ENE wind, 0.00 inches rain/24hrs --- SBBSecho 3.11-Linux
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Underminer@1:103/705 to Digital Man on Saturday, July 18, 2020 18:58:19
    Re: SBBSEcho and BRE
    By: Digital Man to Underminer on Sat Jul 18 2020 04:39 pm

    Would be happy to address the issue, but I don't use BRE, so you'll have to give more details. What file ie BRE creating, exactly? If it's a
    is being created? A little more debugging on your end is going to be needed to identify where the issue is.
    digital man

    I think I've figured out what SBBSecho is doing, but I'll run a couple more tests in a day or two on the old system and report back with hopefully much better information. In the meantime I just wrote a bash script to create the .flo files directly and bypass the issue.
    ---
    Underminer
    The Undermine BBS - bbs.undermine.ca:423
    Fidonet: 1:342/17
    ---
    Synchronet The Undermine - bbs.undermine.ca:423
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)